Jetty es un servidor HTTP 100% basado en Java y un contenedor de Servlets escrito en Java. Jetty se publica como un proyecto de software libre bajo la licencia Apache 2.0.

Jetty es utilizado por otros proyectos, como por ejemplo los servidores de aplicación JBoss y Apache Geronimo; y por el plug-in Google Web Toolkit para Eclipse. Otros servidores de aplicaciones propietarios también lo usan, como por ejemplo My webMethods Server (de Software AG)

El desarrollo de Jetty se enfoca en crear un servidor web sencillo, eficiente, empotrable y pluggable. El tamaño tan pequeño de Jetty lo hace apropiado para ofrecer servicios Web en una aplicación Java empotrada.

El soporte Java en el Google App Engine está construido sobre Jetty.

Historial de versiones Jetty comenzó en 1995 y se alojaba en el servidor MortBay, creándose las versiones 1.x y 2.x, hasta el año 2000. De 2000 a 2005, Jetty se alojó en sourceforge.net, mientras fueron producidas y lanzadas las versiones 3.x, 4.x, y 5.x. En 2005, el proyecto completo se mudó a codehaus.org, a causa de sus servicios de alojamiento y su comunidad open source. En 2009, los principales componentes de Jetty habían sido trasladados a Eclipse.org, y Codehaus.org continúa suministrando integración, extensiones y empaquetamiento., About Jetty Located on Codehaus., About Jetty Located on Eclipse. En enero de 2009, Webtide anunció que Jetty podría estar pasándose a Eclipse Foundation. El código inicial de Jetty 7 fue chequeado en Subversion.

Versión Servidor Versión de Java Versión de HTTP Versión del Servlet Versión de JSP Estado 9.x Eclipse 1.7-1.8 HTTP/1.1 RFC2616, WebSocket, SPDY 3.0 (tracking 3.1 drafts) 2.2 Estable 8.x Eclipse,Codehaus 1.6 HTTP/1.1 RFC2616, WebSocket, SPDY 3.0 2.1 Estable 7.x Eclipse,Codehaus 1.5, J2ME HTTP/1.1 RFC2616, WebSocket, SPDY 2.5 2.1 Estable 6.x Codehaus 1.4-1.5 HTTP/1.1 RFC2616 2.5 2.0 Maduro 5.x Sourceforge 1.2-1.5 HTTP/1.1 RFC2616 2.4 2.0 Obsoleto 4.x Sourceforge 1.2, J2ME HTTP/1.1 RFC2616 2.3 1.2 Antiguo 3.x Sourceforge 1.2 HTTP/1.1 RFC2068 2.2 1.1 Fósil 2.x Mortbay 1.1 HTTP/1.0 RFC1945 2.1 1.0 Legendario 1.x Mortbay 1.0 HTTP/1.0 RFC1945 Mítico

Referencias

Véase también

Tomcat JavaServer Pages Java 2 Enterprise Edition Java Servlet Servicio Web

Enlaces externos Página oficial (en inglés) Wiki oficial de Jetty (en inglés) (en inglés) Wiki de Jetty en Eclipse

Categoría:Servidores web Categoría:Software libre programado en Java Categoría:Servidores de aplicaciones para Java