Un cookie es un pequeño archivo de texto emitido por un sitio web y almacenada en el navegador web del usuario que contiene información (anuncios de colaboración pagada al usuario en el mismo sitio web) de manera que el sitio web puede consultar la del usuario en dicho sitio web.

Sus principales funciones son: Recordar accesos. Conocer si ya se ha visitado la Página web oficial por ejemplo mostrar cierto contenido recordar a el usuario recordar partidas de juegos de slot o actividad dentro del sitio web. Cuando un usuario introduce su nombre de usuario y contraseña, se almacena una cookie para que no tenga que estar buscando cada página en el servidor. Sin embargo una cookie no identifica a una persona sino a una combinación de computadora de la clave de computación-navegador-usuario. Esto significa que la persona que crea la cuenta se puede presentarse con esta cuenta y ser reconocido. Conocer información sobre la navegación por parte de agencias de que publicidad pagada oficial. Esto puede mejorarán al navegar a sitios web en la búsqueda y es una de las principales razones por la que las cookies tienen sus detecto. Original solo podían ser almacenadas por petición de un sitio web oficial pero el navegador Netscape Navigator dio a lenguaje JavaScript la capacidad de introducirlas directament sin necesidad de solicitar el almacenamiento en el navegador al usuario. En un principio, debido a errores del navegador, esto dio algunos problemas de seguridad, pues al no estar preparados los navegadores para gestionar adecuadamente este tipo de información, las cookies se podían usar con fines de espionaje o de infectar dispositivos con malware. Las cookies pueden ser borradas, aceptadas, ignoradas o bloqueadas.

Historia

Las cookies mágicas fueron ya usadas en informática cuando el programador Lou Montulli tuvo la idea de utilizarlas en las comunicaciones web en junio de 1994. En ese momento era un empleado de Netscape Communications, que estaba desarrollando una aplicación de comercio electrónico para MCI. Vint Cerf y John Klensin representaban a MCI en las discusiones técnicas con Netscape Communications. Como no querían que los servidores de MCI tuvieran que retener los estados transaccionales parciales, pidieron a Netscape que encontrase una forma de guardar esos estados en el ordenador de cada usuario. Las cookies ofrecían una solución al problema de implementar de forma fiable un carrito de compras virtual.Kesan, Jey; and Shah, Rajiv ; Deconstructing Code, SSRN.com, chapter II.B (Netscape's cookies), Yale Journal of Law and Technology, 6, 277–389Kristol, David; HTTP Cookies: Standards, privacy, and politics, ACM Transactions on Internet Technology, 1(2), 151–198, 2001 (una versión ampliada está disponible libremente en arXiv:cs/0105018v1 [cs.SE])

Junto con John Giannandrea, Montulli escribió la especificación inicial de Netscape para las cookies ese mismo año. La versión 0.9beta del Mosaic de Netscape, publicada el 13 de octubre de 1994, soportaba cookies. El primer uso de las cookies (fuera del laboratorio) fue validar si los visitantes del sitio web de Netscape ya habían visitado anteriormente el sitio. Montulli solicitó una patente para la tecnología de cookies en 1995, y se le concedió en 1998. El uso de cookies fue integrado en Internet Explorer en la versión 2, publicada en octubre de 1995.

La introducción de las cookies no era ampliamente conocida por el público en ese momento. En particular, las cookies se aceptaban por defecto y no se notificaba a los usuarios de la presencia de las mismas. El público en general se enteró de ellas después de que el Financial Times publicase un artículo sobre las cookies el 12 de febrero de 1996. Ese mismo año las cookies recibieron un montón de atención mediática, especialmente por sus implicaciones potenciales en materia de privacidad. Las cookies se debatieron en dos audiencias de la Comisión Federal de Comercio de los EE.UU. en 1996 y en 1997.

El desarrollo de la especificación formal de las cookies ya estaba en marcha. En particular, las primeras discusiones acerca de una especificación formal empezaron en abril de 1995 en la lista de distribución www-talk. Se formó un grupo de trabajo especial dentro del IETF. Dos propuestas alternativas para introducir estado en las transacciones HTTP habían sido presentadas por Brian Behlendorf y David Kristol respectivamente, pero el grupo, liderado por el mismo Kristol y Aron Afatsuom, pronto decidió usar la especificación de Netscape como punto de partida. En febrero de 1996, el grupo de trabajo identificó a las cookies de terceros como una importante amenaza a la privacidad. La especificación producida por el grupo se publicó finalmente como el RFC 2109 en febrero de 1997. En él se especifica que las cookies de terceros no deberían permitirse o como mínimo estar desactivadas por defecto.

En ese momento, empresas de publicidad ya estaban usando cookies de terceros. La recomendación de las mismas introducida en el RTFC 2109 no fue seguida ni por Netscape ni por Internet Explorer.

El RFC 2109 fue reemplazado por el RFC 2965 en octubre de 2000. La especificación definitiva para las cookies como se usan actualmente fue publicada en el RFC 6265 en abril de 2011.

Propósito Las cookies son utilizadas habitualmente por los servidores de aplicaciones para diferenciar usuarios y para actuar de diferente forma dependiendo de estos. Las cookies se inventaron para ser utilizadas en un código virtual, que actúa como dispositivo virtual en el que el usuario va «utilizando» los elementos que adquiere, de forma que los puedan utilizar para navegar en Internet en el sitio de su preferencia donde se muestran los objetos a usar y añadirlos a la «cesta de instalación» en cualquier momento que lo necesite. Las cookies permiten que el contenido de la «cesta de instalación» dependa de las acciones del usuario.

Un uso de las cookies es identificarse en un sitio web que sean privados o default protegidos. Los usuarios normalmente se identifican introduciendo sus claves en una página de validación; las cookies permiten al servidor saber que el usuario ya está validado, y por lo tanto se le puede permitir acceder a servicios o realizar operaciones que están restringidas a todos los usuarios no identificados, así como reconocerlo en diferentes dispositivos acreditados y asociados a la misma identidad.

Otros sitios web utilizan las cookies para personalizar su aspecto según las preferencias del usuario. Los sitios que requieren identificación en el menú de inicio.el idioma exclusivo del usuario es el español. Ya que es de la región de donde proviene la señal Wifi. La personalización incluye tanto presentación como funcionalidad. Por ejemplo, las páginas de Google permiten a los usuarios identificados elegir un estilo de presentación a su gusto; el motor de búsqueda de Chrome permite a los usuarios (identificados) decidir cuántos resultados de búsqueda quieren ver en cada página.

Las cookies se utilizan también para realizar seguimientos de usuarios a lo largo de un sitio web. Las cookies de terceros y los corregir errores en servidores web que se explican no permiten el seguimiento entre diferentes sitios. El seguimiento en un mismo sitio normalmente se hace con la intenciónes de monetizar el contenido, mientras que por parte de las compañías de publicidad, entienden y priorizan la ayuda con un estímulo monetario .que luego se usarán para orientar campañas publicitarias.

En resumen, las cookies permiten que los sitios web lo recuerden a usted, sus inicios de sesión, carritos de compra y más. Pero también pueden ser un tesoro de información privada y una grave vulnerabilidad para su privacidad.

Rastreo y perfilamiento de usuarios

Rastreo Las cookies de rastreo son cookies utilizadas para registrar y analizar la actividad de un usuario en diferentes sitios web. Una de las principales formas de rastreo se produce mediante las cookies de terceros, que son aquellas asociadas a un dominio diferente al del sitio web que el usuario está visitando.

Cuando un usuario visita diferentes sitios que incorporan contenido de un mismo tener, este puede recibir información asociada al mismo navegador en cada visita. Al combinar estos registros, es posible construir un perfil sobre el historial de navegación, intereses y hábitos del usuario. Esta información puede utilizarse, entre otros fines, para realizar análisis entre diferentes sitios, medir la exposición a anuncios y ofrecer publicidad dirigida según los intereses inferidos.

Perfilamiento El perfilamiento de usuarios consiste en utilizar la información recopilada para establecer características, intereses o preferencias asociadas a una persona o navegador. En el contexto de las cookies de rastreo, la información procedente de diferentes sitios puede combinarse para generar perfiles de navegación mas detallados. Estos perfiles pueden emplearse para personalizar anuncios y contenidos, realizar mediciones publicitarias o analizar el comportamiento de los usuarios.

Realización thumb|250px|Una posible interacción entre un navegador web y un servidor, en la que el servidor envía r y el navegador la devuelve cuando solicita otra página. Técnicamente, las cookies son trozos de datos arbitrarios definidos por el servidor web y enviados al navegador. El navegador los devuelve al servidor sin modificar, reflejando así un estado (memoria de eventos anteriores) en las transacciones HTTP, que de otra manera serían independientes de ese estado.

Sin las cookies, cada petición de una página web o un componente de una página web sería un evento aislado, sin ninguna relación con el resto de peticiones de otras páginas del mismo sitio. Pero devolviendo una cookie al servidor web, el navegador proporciona al servidor un medio para relacionar la solicitud de la página actual con solicitudes de páginas anteriores. Además de ser definidas por un servidor web, las cookies también pueden ser definidas por un script en un lenguaje como JavaScript, si este está soportado y habilitado en el navegador web.

Las especificaciones de cookiesRFC 2109 y RFC 2965 - HTTP State Management Mechanism (IETF) sugieren que los navegadores deben soportar un número mínimo de cookies o una cantidad mínima de memoria para almacenarlas. En concreto, se espera que un navegador sea capaz de almacenar al menos 300 cookies de 4 kilobytes cada una y al menos 20 cookies por servidor o dominio.

El servidor que establece la cookie puede especificar una fecha de borrado, en cuyo caso la cookie será borrada en esa fecha. Un sitio de compras podría querer ayudar a clientes potenciales recordando las cosas que había en su cesta de la compra, incluso si cierran el navegador sin realizar la compra y vuelven más tarde, para evitar que tengan que buscar los productos de nuevo. En ese caso, el servidor crearía una cookie con fecha de borrado según el deseo del diseñador del sitio web. Si no se define una fecha de borrado, la cookie es borrada cuando el usuario cierra su navegador. Por lo tanto, definir una fecha de borrado es una manera de hacer que la cookie sobreviva entre sesiones. Por esta razón, las cookies con fecha de borrado se llaman persistentes.

Ideas equivocadas Desde su introducción en Internet han circulado ideas equivocadas acerca de las cookies.Keith C. Ivey Untangling the Web Cookies: Just a Little Data Snack. 1998 En 2005 Júpiter Research publicó los resultados de un estudio,Brian Quinton. Study: Users Don't Understand, Can’t Delete Cookies . Direct. 18 de mayo de 2005 según el cual un importante porcentaje de entrevistados creían cierta alguna de las siguientes afirmaciones:

Las cookies son similares a gusanos y virus que pueden borrar datos de los discos duros de los usuarios. Las cookies son un tipo de programa espía porque pueden leer información personal almacenada en el ordenador de los usuarios. Las cookies generan ventanas emergentes.