CalDAV (Calendaring Extensions to WebDAV) é um protocolo da Internet que permite que um cliente aceda a informação agendada num servidor remoto.
A especificação CalDAV foi inicialmente desenvolvida por Lisa Dusseault em 2003 como um rascunho para o Internet Engineering Task Force (IETF). A especificação rapidamente atraiu apoio de desenvolvedores de softwares de calendário. Em Janeiro de 2005, um teste de interoperabilidade entre os dois servidores e três clientes funcionou conjuntamente com sucesso. O protocolo CalDAV foi publicado como Extensões de Calendário RFC 4791 padrão do IETF para WebDAV (CalDAV). Desde então, o CalDAV foi desenvolvido para implementação em qualquer software de calendário. Aqui, o protocolo CalDAV gere o acesso à informação de acordo com regras de acesso claramente definidas. O protocolo foi projectado como um padrão aberto que desenvolvedores podem livre e independentemente implementar nas suas próprias plataformas.
O trabalho do CalDAV é gerir eventos (referindo-se a marcações) como encontros, assembleias (encontro entre grupos de pessoas), e os tempos livres/ocupados. Cada evento é escrito em formato iCalendar. Consequentemente, qualquer software cliente pode exibir um evento iCalendar descarregado na sua representação. Os dados são geridos e sincronizados como registros num servidor WebDAV e no ambiente do cliente. O protocolo CalDAV complementa o HTTP – (RFC 2616) e o protocolo WebDAV (RFC 2518) executa as funções. Com esta funcionalidade um utilizador pode sincronizar o seu calendário com o servidor CalDAV e partilhá-lo com vários dispositivos e outros utilizadores. O protocolo também suporta a visualização de calendários não pessoais, como os de salas e organizações.
Alguns desenvolvedores criticam a complexidade do CalDAV porque é difícil implementá-lo e pode levar a erros de implementação em diferentes aplicações de gestão de calendário, o que por sua vez pode levar a incompatibilidades.
Exemplo Pedido: REPORT /bernard/work/ HTTP/1.1 Host: cal.example.com Depth: 1 Content-Type: application/xml; charset="utf-8" Content-Length: xxxx
<?xml version="1.0" encoding="utf-8" ?> <C:free-busy-query xmlns:C="urn:ietf:params:xml:ns:caldav"> <C:time-range start="20060104T140000Z" end="20060105T220000Z"/> </C:free-busy-query> Resposta: HTTP/1.1 200 OK Date: Sat, 11 Nov 2006 09:32:12 GMT Content-Type: text/calendar Content-Length: xxxx
BEGIN:VCALENDAR VERSION:2.0 PRODID:-//Example Corp.//CalDAV Server//EN BEGIN:VFREEBUSY DTSTAMP:20050125T090000Z DTSTART:20060104T140000Z DTEND:20060105T220000Z FREEBUSY;FBTYPE=BUSY-TENTATIVE:20060104T150000Z/PT1H FREEBUSY:20060104T190000Z/PT1H END:VFREEBUSY END:VCALENDAR
Software Cliente A lista de clientes CalDAV inclui: : CalDAV Tasksync for Android TaskSync CalDAV-Sync for Android CalDAV-Sync CalendarSync for Android CalendarSync DAVdroid for Android DAVdroid AgenDAV iPhone Atmail CalDavZAP CalDavZAP EVO Collaborator for Outlook EVO Collaborator for Outlook Evolution Horde GroupwareHorde Groupware Korganizer Sunbird Thunderbird with the Lightning plug-in eM Client iCal4OL iCal iCal Import/Export CalDAV for AndroidiCal Import/Export CalDAV
Servidor A lista de servidor CalDAV inclui: : Apples Darwin Atmail BaikalBaikal Lightweight CalDAV+CardDAV server Bedework Bedework Bynari Collaboration SuiteBynari Collaboration Suite Chandler Server CommuniGate Pro DAViCalDAViCal DPCalendarDPCalendar DavMail Daylite CalDAV ServerDaylite CalDAV Server Dingo Calendar Server EGroupware EVO Mail ServerEVO Mail Server Fabasoft Folio Cloud Google CalenderGoogle Calendar Horde Groupware Icewarp-E-Mail-Server Kerio ConnectKerio Connect Open-Xchange Oracle Beehive Oracle Communications Calendar ServerOracle Communications Calendar Server Radicale (CalDAV)Radicale SOGoSOGo SabreDAVsabre/dav ScalixScalix Sun Java Calendar Server Synovel CollabSuiteSynovel Yahoo Calender Zarafa Zimbra Since version 4.5Zimbra mod_caldavmod_caldav auf SourceForge ownCloudownCloud sync!Egwsync!Egw
Ligações externas WebDAV-Information CalDAV-Website Proposed calendar enhancement for WebDAv (CalDAV) Scheduling Association CalDAV-Roadmap MozillaWiki RFC-dependencies RFC 2518 - WebDAV RFC 2616 - HTTP RFC 3744 - WebDAV Access Control Protocol RFC 4791 - Calendaring Extensions to WebDAV (CalDAV) RFC 5545 - iCalendar
Categoria:Protocolos da Internet