ISO 639-1 es la primera parte del código ISO 639. Consiste en 184 códigos de dos letras usados para identificar los principales idiomas del mundo. Estos códigos son una taquigrafía internacional muy útil para indicar idiomas. Por ejemplo: El español está representado por es El inglés está representado por en El alemán está representado por de (del endónimo Deutsch) El japonés está representado por ja (aunque su endónimo es Nihongo)
La lista de códigos ISO 639-1 se convirtió en norma oficial en 2002, aunque ha existido en formato borrador desde hace años. El último código añadido fue ht, representando al criollo haitiano el 26 de febrero de 2003. El uso de la norma fue apoyado por IETF language tags, introducido por RFC 1766 en marzo de 1995, y continuado por RFC 3066 en enero de 2001 y por RFC 4646 en septiembre de 2006.
No se añaden nuevos códigos ISO 639-1 a las lenguas que tengan código ISO 639-2 propio. Los sistemas que usan códigos ISO 639-1 y 639-2 con código 639-1 preferido, no tienen que cambiar sus códigos.
Si un código ISO 639-2 que cubre un grupo de lenguas es usado, puede volverse obsoleto por un código ISO 639-1 para algunos datos.
+ Códigos ISO 639-1 añadidos después de la publicación del RFC en enero de 2001ISO 639-1ISO 639-2NombreFecha de añadidoCubierto previamente porioidoIdo15-01-2002artwawlnValón29-01-2002roalilimLimburgués02-08-2002gemiiiiiYi de Sichuán14-10-2002sitanargAragonés23-12-2002roahthatCreole haitiano26-02-2003cpf
Lista idiomas A continuación, la lista de lenguas ordenadas alfabéticamente siguiendo el estándar ISO 639-1
{| class="sortable wikitable" ! código ! idioma |- |aa || afar |- |ab || abjasio (o abjasiano) |- |ae || avéstico |- |af || afrikáans |- |ak || akano |- |am || amhárico |- |an || aragonés |- |ar || árabe |- |as || asamés |- |av || avar (o ávaro) |- |ay || aimara |- |az || azerí |- |ba || baskir |- |be || bielorruso |- |bg || búlgaro |- |bh || bhoyapurí |- |bi || bislama |- |bm || bambara |- |bn || bengalí |- |bo || tibetano |- |br || bretón |- |bs || bosnio |- |ca || catalán |- |ce || checheno |- |ch || chamorro |- |co || corso |- |cr || cree |- |cs || checo |- |cu || eslavo eclesiástico antiguo |- |cv || chuvasio |- |cy || galés |- |da || danés |- |de || alemán |- |dv || maldivo (o dhivehi) |- |dz || dzongkha |- |ee || ewé |- |el || griego (moderno) |- |en || inglés |- |eo || esperanto |- |es || español (o castellano) |- |et || estonio |- |eu || euskera |- |fa || persa |- |ff || fula |- |fi || finés (o finlandés) |- |fj || fiyiano (o fiyi) |- |fo || feroés |- |fr || francés |- |fy || frisón (o frisio) |- |ga || irlandés (o gaélico) |- |gd || gaélico escocés |- |gl || gallego |- |gn || guaraní |- |gu || guyaratí (o gujaratí) |- |gv || manés (gaélico manés o de Isla de Man) |- |ha || hausa |- |he || hebreo |- |hi || hindi (o hindú) |- |ho || hiri motu |- |hr || croata |- |ht || haitiano |- |hu || húngaro |- |hy || armenio |- |hz || herero |- |ia || interlingua |- |id || indonesio |- |ie || occidental |- |ig || igbo |- |ii || yi de Sichuán |- |ik || iñupiaq |- |io || ido |- |is || islandés |- |it || italiano |- |iu || inuktitut (o inuit) |- |ja || japonés |- |jv || javanés |- |ka || georgiano |- |kg || kongo (o kikongo) |- |ki || kikuyu |- |kj || kuanyama |- |kk || kazajo (o kazajio) |- |kl || groenlandés (o kalaallisut) |- |km || camboyano (o jemer) |- |kn || canarés |- |ko || coreano |- |kr || kanuri |- |ks || cachemiro (o cachemir) |- |ku || kurdo |- |kv || komi |- |kw || córnico |- |ky || kirguís |- |la || latín |- |lb || luxemburgués |- |lg || luganda |- |li || limburgués |- |ln || lingala |- |lo || lao |- |lt || lituano |- |lu || luba-katanga (o chiluba) |- |lv || letón |- |mg || malgache (o malagasy) |- |mh || marshalés |- |mi || maorí |- |mk || macedonio |- |ml || malayalam |- |mn || mongol |- |mr || maratí |- |ms || malayo |- |mt || maltés |- |my || birmano |- |na || nauruano |- |nb || noruego bokmål |- |nd || ndebele del norte |- |ne || nepalí |- |ng || ndonga |- |nl || neerlandés (u holandés) |- |nn || nynorsk |- |no || noruego |- |nr || ndebele del sur |- |nv || navajo |- |ny || chichewa |- |oc || occitano |- |oj || ojibwa |- |om || oromo |- |or || oriya |- |os || osético (u osetio, u oseta) |- |pa || panyabí (o penyabi) |- |pi || pali |- |pl || polaco |- |ps || pastú (o pastún, o pashto) |- |pt || portugués |- |qu || quechua |- |rm || romanche |- |rn || kirundi |- |ro || rumano |- |ru || ruso |- |rw || ruandés (o kiñaruanda) |- |sa || sánscrito |- |sc || sardo |- |sd || sindhi |- |se || sami septentrional |- |sg || sango |- |si || cingalés |- |sk || eslovaco |- |sl || esloveno |- |sm || samoano |- |sn || shona |- |so || somalí |- |sq || albanés |- |sr || serbio |- |ss || suazi (o swati, o siSwati) |- |st || sesotho |- |su || sundanés (o sondanés) |- |sv || sueco |- |sw || suajili |- |ta || tamil |- |te || télugu |- |tg || tayiko |- |th || tailandés |- |ti || tigriña |- |tk || turcomano |- |tl || tagalo |- |tn || setsuana |- |to || tongano |- |tr || turco |- |ts || tsonga |- |tt || tártaro |- |tw || twi |- |ty || tahitiano |- |ug || uigur |- |uk || ucraniano |- |ur || urdu |- |uz || uzbeko |- |ve || venda |- |vi || vietnamita |- |vo || volapük |- |wa || valón |- |wo || wolof |- |xh || xhosa |- |yi || yídish (o yidis, o yiddish) |- |yo || yoruba |- |za || chuan (o chuang, o zhuang) |- |zh || chino |- |zu || zulú
Tabla de códigos asignados o reservados La siguiente tabla muestra una de las tres partes de la norma ISO 639-1. También permite que, haciendo clic en un elemento de código, vaya a la página de la enciclopedia que detalla la información de los códigos ISO 639-1 correspondientes a cada idioma.
Tabla de códigos ISO 639-1-1 asignados y utilizadosAA AfarAB AbjasioACADAE AvésticoAF AfrikáansAGAHAIAJAK AkanoALAM AmháricoAN AragonésAOAPAQAR ÁrabeAS AsamésATAUAV AvarAWAXAY AimaraAZ AzeríBA BaskirBBBCBDBE BielorrusoBFBG BúlgaroBH BhoyapuríBI BislamaBJBKBLBM BambaraBN BengalíBO TibetanoBPBQ<tt>BR BretónBS Bosnio BTBUBVBWBXBYBZCA CatalánCBCCCDCE ChechenoCFCGCH ChamorroCICJCKCLCMCNCO CorsoCPCQCR CreeCS ChecoCTCU EslavoCVCWCXCY GalésCZDA Danés DBDCDDDE AlemánDFDGDHDIDJDKDLDMDNDODPDQDRDSDTDUDV MaldivoDWDXDYDZ DzongkhaEAEBECEDEE EwéEFEGEHEIEJEKEL GriegoEMEN InglésEO EsperantoEPEQERES EspañolET EstonioEU EuskeraEVEWEXEYEZFA PersaFBFCFDFEFF FulaFGFHFI FinésFJ FiyianoFKFLFMFNFO FeroésFPFQFR FrancésFSFTFUFVFWFXFY FrisónFZGA IrlandésGBGCGD Gaélico escocésGEGFGGGHGIGJGKGL GallegoGMGN GuaraníGOGPGQGRGSGTGU GuyaratíGV ManésGWGXGYGZHA HausaHBHCHDHE HebreoHFHGHHHI HindiHJHKHLHMHNHO HirimotuHPHQHR CroataHSHT HaitianoHU HúngaroHVHWHXHY ArmenioHZ HereroIA InterlinguaIBICID IndonesioIE OccidentalIF Igbo IG IH II Yi de Sichuán IJ IK Iñupiaq IL IM IN IO Ido IP IQ IR IS Islandés IT Italiano IU Inuktitut IV IW IX IY IZ JA JaponésJBJC JD JEJFJGJHJIJJJKJL JM JN JO JP JQ JR JS JT JU JV JavanésJW JX JY JZKA GeorgianoKBKCKDKEKFKG KongoKHKI KikuyuKJ KuanyamaKK KazajoKL GroenlandésKM CamboyanoKN CanarésKO CoreanoKPKQKR KanuriKS CachemirKTKU KurdoKV KomiKW CórnicoKXKY KirguísKZLA LatínLB LuxemburguésLCLDLELF LugandaLGLHLILJLKLLLMLNLO LaoLPLQLRLSLT LituanoLU Luba-katangaLV LetónLWLXLYLZMAMBMC MD ME MF MG Malgache MH Marshalés MI Maorí MJ MK Macedonio ML Malayam MM Mongol MN MO MP MQ MR Maratí MS Malayo MT Maltés MU MV MW MX MY Birmano MZ NA NauruanoNB Noruego BokmålNCND Ndebele del norteNE NepalíNF NG Ndonga NH NI NJ NK NL Neerlandés NM NN Nynorsk NO Noruego NP NQ NR Ndebele del sur NS NT NU NV Navajo NW NX NY Chichewa NZ OA OB OC Occitano OD OE OF OG OH OI OJ Ojibwa OK OL OM Oromo ON OO OP OO OR Oriya OS Osetio OT OU OV OW OX OY OZ PA PanyabíPBPCPDPEPFPGPHPI PaliPJ PK PL Polaco PM PN PO PP PQ PR PS Pastún PT Portugués PU PV PW PX PY PZ QAQBQCQDQE QF QG QH QI QJ QK QL QM QN QO QP QQ QR QS QT QU Quechua QV QW QX QY QZ RA RB RC RD RERF RG RH RI RJ RK RL RM Romanche RN Kirundi RO Rumano RP RQ RR RS RT RU RusoRV RW Ruandés RX RY RZ SA SánscritoSBSC SardoSD SindhiSE SamiSFSG SangoSH SI Cingalés SJ SK Eslovaco SL Esloveno SM Samoano SN Shona SO Somalí SP SQ Albanés SR Serbio SS Suazi ST Sesotho SU Sundanés SV Sueco SW Suajili SX SY SZTA TamilTB Télugu TC TD TE TF TG Tayiko TH Tailandés TI Tigriña TJ TK Turcomano TL Tagalo TM TN Setsuana TO Tongano TP TQ TR Turco TS Tsonga TT Tártaro TU TV TW Twi TX TY Tahitiano TZ TamazightUAUB UC UD UE UF UG Uigur UH UI UJ UK Ucraniano UL UM UN UO UP UQ UR Urdu US UT UU UV UW UX UY UZ Uzbeco VA VB VC VD VE Venda VF VG VH VI Vietnamita VJ VK VL VM VN VO Volapük VP VQ VR VS VT VU VV VW VX VY VZ WA Valón WB WC WD WE WF WG WH WI WJ WK WL WM WN WO Wólof WP WQ WR WS WT WU WV WW WX WY WZ XA XB XC XD XE XF XG XH Xhosa XI XJ XK XL XM XN XO XP XQ XR XS XT XU XV XW XX XY XZ YA YB YC YD YE YF YG YH YI Yídish YJ YK YL YM YN YO Yoruba YP YQ YR YS YT YU YV YW YX YY YZ ZA ZB ZC ZD ZE ZF ZG ZH Chino ZI ZJ ZK ZL ZM ZN ZO ZP ZQ ZR ZS ZT ZU Zulú ZV ZW ZX ZY ZZ Leyendas de los colores de las celdas ColorEstadoSignificado Código oficialmente asignadoCódigo oficial del idioma indicado, según ISO 639-1. Código no asignadoCódigo no asignado ni reservado actualmente, en la norma ISO 3166-1 Código oficialmente asignado a lengua con más de 500.000.000 hablantes (Top 3) Clasificación según Ethnologue de 2015 Código oficialmente asignado a lengua con más de 250.000.000 hablantes (Top 5) Código oficialmente asignado a lengua con más de 200.000.000 hablantes (Top 10)
Véase también Idioma ISO 639-2 ISO 639-3 Organización Internacional de Normalización
Enlaces externos ISO 639-1 ISO 639-1/RA. ISO 639-1:2002 standard.
Categoría:Identificadores de idiomas #00639-1